Compatibility Charts

[L] Latest available/tagged version on this branch.
[NS] Version isn't normally supported anymore. (This doesn't indicate abandonment nor EOL. It indicates that when seeking support for this version, the most likely outcome will be a recommendation to update to a newer version; i.e., there may be bugs present within this version, fixed since newer versions, with updating being a much more efficient and practical solution than attempting to provide support for this version).
[TBA] Version hasn't been released yet. (Planned or still under development).
[CR] Contextual release. (Mightn't have the same availability as other releases, or may be available only in specific contexts).

[A] This version/release is an alpha. You could use it in production, but doing so is not recommended.
[B] Critical bugs or unintended breaks detected in this version (meaning that the version is effectively unusable). Avoid usage!
[BC] This version/release significantly breaks backwards-compatibility. When updating from an earlier version, review all changes carefully.
[F] Final expected version. Future releases aren't expected on any branch. This generally suggests abandonment or EOL ("end of life") status.
[FB] Final expected version on this branch. Future releases aren't expected on this branch, but may occur on other, newer braches.
[V] Security vulnerabilities have been identified belonging to this version/release. Avoid usage!

See also:
Vulnerability Charts
PHP releases

Compatibility Charts
Last modified:
Only relevant information will be listed here. Information will be delisted when no longer relevant.
If you find any errors, if you'd like to add something to the list, or to make some changes, please send a pull request to the GitHub repository for this page.
Licensing (for this repository): MIT License (feel free to copy and adapt it if you want).
[NS] CIDRAM-L 1.13.3 (2020.05.26)

[NS] CIDRAM-L 1.14.0 (2021.01.10)
[NS] CIDRAM-L 1.15.0 (2021.02.18)
[NS] CIDRAM-L 1.15.1 (2021.04.11)
[B] [NS] CIDRAM-L 1.16.0 (2021.05.30)
CIDRAM-L 1.16.1 (2021.05.30)
CIDRAM-L 1.16.2 (2021.06.18)
CIDRAM-L 1.17.0 (2021.07.02)
CIDRAM-L 1.18.0 (2021.08.11)
[L] CIDRAM-L 1.19.0 (2021.11.11)
[NS] CIDRAM 1.12.0 (2019.04.30)

CIDRAM 1.17.1 (2020.05.01)
CIDRAM 1.17.2 (2020.06.19)
CIDRAM 1.17.3 (2020.07.03)
CIDRAM 1.17.4 (2020.10.05)
CIDRAM 1.18.0 (2021.03.03)
CIDRAM 1.18.1 (2021.04.11)
CIDRAM 1.19.0 (2021.07.02)
[L] CIDRAM 1.20.0 (2021.11.21)
PHP >=5.4.0 required PHP >=7.2.0 recommended
Requires PHP >=5.4.0 w/ PCRE support (PHP >=7.2.0 recommended).
(cURL, APCU, Memcached, Redis, PDO support also recommended).

Available via Composer/Packagist: CIDRAM v1.
Not available via Composer/Packagist: CIDRAM-L v1.
[NS] CIDRAM 2.0.0 (2019.06.01)

CIDRAM 2.4.1 (2020.05.01)
CIDRAM 2.4.2 (2020.06.19)
CIDRAM 2.4.3 (2020.07.03)
CIDRAM 2.4.4 (2020.10.05)
[NS] [CR] CIDRAM (WP Only) 2.4.5 (2021.02.24)
CIDRAM 2.5.0 (2021.03.03)
CIDRAM 2.5.1 (2021.04.11)
CIDRAM 2.6.0 (2021.07.02)
[NS] [CR] CIDRAM (WP Only) 2.6.1 (2021.08.15)
[L] CIDRAM 2.7.0 (2021.11.21)
[TBA] CIDRAM 3.0.0 (T.B.A.)
PHP >=7.2.0 required
Requires PHP >=7.2.0 w/ PCRE support.
(cURL, APCU, Memcached, Redis, PDO support also recommended).

Available via Composer/Packagist: CIDRAM >=v2.
Not available via Composer/Packagist: CIDRAM (WP Only) v[Any].

Note: The external CLI tool for CIDRAM >=v2 is *not* compatible specifically with PHP 7.4.0.
It is, however, compatible with PHP >=7.2.0 <7.4.0, and PHP >=7.4.1 onward.
[NS] phpMussel 1.10.0 (2019.04.30)

phpMussel 1.13.3 (2020.06.15)
phpMussel 1.13.4 (2020.06.19)
phpMussel 1.13.5 (2020.07.03)
phpMussel 1.13.6 (2020.10.01)
phpMussel 1.14.0 (2020.12.04)
phpMussel 1.14.1 (2021.04.10)
phpMussel 1.14.2 (2021.05.22)
[L] phpMussel 1.15.0 (2021.10.31)
PHP >=5.4.0 required PHP >=7.2.0 recommended
Requires PHP >=5.4.0 w/ PCRE support (PHP >=7.2.0 recommended).
(cURL, Bz2, Lzf, Rar, Zip, zlib, APCU, Memcached, Redis, PDO support also recommended).

Available via Composer/Packagist.

Note: phpMussel's "CLI mode" is *not* compatible specifically with PHP 7.4.0.
It is, however, compatible with PHP >=5.4.0 <7.4.0, and PHP >=7.4.1 onward.
[NS] phpMussel 2.0.0 (2019.08.31)

phpMussel 2.1.3 (2020.06.15)
phpMussel 2.1.4 (2020.06.19)
phpMussel 2.1.5 (2020.07.03)
phpMussel 2.1.6 (2020.10.01)
phpMussel 2.2.0 (2020.12.04)
phpMussel 2.3.0 (2021.04.10)
phpMussel 2.3.1 (2021.05.22)
[L] phpMussel 2.4.0 (2021.10.31)
phpMussel 3.0.0 (2020.07.20)
phpMussel 3.0.1 (2020.10.01)
phpMussel 3.0.2 (2020.10.15)
phpMussel 3.1.0 (2020.12.04)
phpMussel 3.2.0 (2021.03.03)
phpMussel 3.2.1 (2021.05.31)
[L] phpMussel 3.3.0 (2021.10.31)
(Includes Core+CLI+FrontEnd+Web)
PHP >=7.2.0 required
Requires PHP >=7.2.0 w/ PCRE support.
(cURL, Bz2, Lzf, Rar, Zip, zlib, APCU, Memcached, Redis, PDO support also recommended).

Available via Composer/Packagist.

Note: phpMussel's "CLI mode" is *not* compatible specifically with PHP 7.4.0.
It is, however, compatible with PHP >=7.2.0 <7.4.0, and PHP >=7.4.1 onward.
[NS] SigTool 0.2.3 (2019.01.25)
SigTool 1.0.0 (2020.03.07)
SigTool 1.0.1 (2020.12.05)
SigTool 1.0.2 (2021.05.22)
[L] SigTool 1.0.3 (2021.07.22)
PHP >=7.0.3 required (>=7.2.0 recommended)
Compatible with phpMussel >=1.0.0 (^1.14.1, >=2.3.0 recommended)
Requires PHP >=7.0.3 w/ PCRE and zlib support (PHP >=7.2.0 recommended).
For SigTool <=1.0.2, phar support also required (not required for >=1.0.3).
At least >=681 MBs of available RAM required (but, at least >=1 GB is strongly recommended).
Generated signature files are compatible with phpMussel >=1.0.0
phpMussel ^1.14.1, >=2.3.0 recommended (due to "signatures.dat" changes).
Generated signature files are NOT compatible with phpMussel <1.0.0

Available via Composer/Packagist.

Note: SigTool for phpMussel, and Sigtool for ClamAV, are two distinct, separate packages.
The information included here relates to the SigTool for phpMussel.
[NS] SFS Mass IP Checker 0.1.3 (2016.09.10)
(Please don't use versions older than this; They are very buggy).

PHP >=5.3.0 required
Requires PHP >=5.3.0 w/ PCRE support.

Available via Composer/Packagist.
[L] SFS Mass IP Checker 1.0.0 (2020.11.25)
PHP >=5.4.0 required
Requires PHP >=5.4.0 w/ PCRE support + cURL support.

Available via Composer/Packagist.
[NS] Cronable 1.0.0 (2017.10.29)
Cronable 1.1.0 (2018.01.20)
Cronable 1.2.0 (2018.09.10)
Cronable 1.2.1 (2020.12.05)
PHP >=5.4.0 required
Compatible with CIDRAM >=1.2.0 (>=1.3.0 recommended)
Compatible with phpMussel >=1.1.0 <3.0.0 (>=1.2.0 <3.0.0 recommended)
Requires PHP >=5.4.0 w/ PCRE support.
Compatible with CIDRAM >=1.2.0 (>=1.3.0 recommended).
Compatible with phpMussel >=1.1.0 <3.0.0 (>=1.2.0 <3.0.0 recommended).

Available via Composer/Packagist.
[L] Cronable 1.2.2 (2021.07.14)
PHP >=5.4.0 required
Compatible with CIDRAM >=1.2.0 (^1.19.1, >=2.6.1 recommended)
Compatible with phpMussel >=1.1.0 <3.0.0 (^1.15.0, ^2.4.0 recommended)
Requires PHP >=5.4.0 w/ PCRE support.
Compatible with CIDRAM >=1.2.0 (^1.19.1, >=2.6.1 recommended).
Compatible with phpMussel >=1.1.0 <3.0.0 (^1.15.0, ^2.4.0 recommended).

Available via Composer/Packagist.
[NS] Aggregator 1.0.0 (2017.09.21)

Aggregator 1.3.0 (2020.01.01)
Aggregator 1.3.1 (2020.06.11)
Aggregator 1.3.2 (2020.12.04)
[L] Aggregator 1.3.3 (2021.10.23)
[NS] Common Classes Package 1.0.0 (2019.02.28)

Common Classes Package 1.4.0 (2020.12.04)
Common Classes Package 1.5.0 (2021.02.22)
Common Classes Package 1.6.0 (2021.04.24)
Common Classes Package 1.6.1 (2021.05.22)
Common Classes Package 1.6.2 (2021.07.02)
[L] Common Classes Package 1.7.0 (2021.10.31)
PHP >=5.4.0 required
Requires PHP >=5.4.0 w/ PCRE support.

Available via Composer/Packagist.
[L] L10NDateSignOff 1.0.0 (2021.02.22)
[NS] Common Classes Package 2.0.0 (2019.05.29)

Common Classes Package 2.4.0 (2020.12.04)
Common Classes Package 2.5.0 (2021.02.22)
Common Classes Package 2.6.0 (2021.04.24)
Common Classes Package 2.6.1 (2021.05.22)
Common Classes Package 2.6.2 (2021.07.02)
[L] Common Classes Package 2.7.0 (2021.10.31)
PHP >=7.2.0 required
Requires PHP >=7.2.0 w/ PCRE support.

Available via Composer/Packagist.
[NS] ZB Block 0.4.10a3 (2013.01.19)
Versions <=0.4.10a3 authored/released by Zaphod.
PHP >=5.0.0 <7.0.0 required
Requires PHP >=5.0.0 <7.0.0 w/ PCRE support.
(Latest PHP version in the required PHP version range is already EoL)

*Might* also be compatible with PHP >=4.3.0, based on manual analysis.
However, PHP versions <5.0.0 don't run correctly at my machines, so I'm unable to confirm this.

Not available via Composer/Packagist.
[NS] [CR] ZB Block 0.4.20 (2018.01.01)
Versions >=0.4.20 authored/released by JamesC.
[NS] ZB Block 0.4.21 (2018.02.01)
PHP >=5.0.0 required
Requires PHP >=5.0.0 w/ PCRE support.

" "

Note: Problems are anticipated for use with PHP 7.4.0 (due to bugs in this PHP version).
These bugs are resolved from PHP >=7.4.1 onward.
[NS] [CR] ZB Block 0.5.0 (2018.02.03)

[NS] [CR] ZB Block 0.6.1 (2018.05.28)
PHP >=5.1.0 required
Requires PHP >=5.1.0 w/ PCRE support.

" "

" "
[NS] [CR] ZB Block 0.6.2 (2018.09.09)
PHP >=5.4.0 required
Requires PHP >=5.4.0 w/ PCRE support.

" "

" "
[NS] [CR] ZB Block 0.6.3 (2018.09.12)

[NS] ZB Block 0.6.7 (2019.11.28)
[NS] [CR] ZB Block 0.6.8 (2019.12.14)
ZB Block 0.7.0 (2020.05.07)
[L] ZB Block 0.7.0b (2020.05.14)
PHP >=5.1.0 required
Requires PHP >=5.1.0 w/ PCRE support.

Not available via Composer/Packagist.

Note: Problems are anticipated for use with PHP 7.4.0 (due to bugs in this PHP version).
These bugs are resolved from PHP >=7.4.1 onward.
Shieldfy PHP SDK 3.1.0 (2018.10.16)

[L] Shieldfy PHP SDK 3.2.1 (2019.04.29)
Shieldfy PHP SDK authored/released by Shieldfy.
PHP >=5.6.0 required
Requires PHP >=5.6.0 w/ PCRE support.

Available via Composer/Packagist.
[NS] NinjaFirewall (WP) 4.1.0 (2020.01.26)

[NS] NinjaFirewall (WP) 4.2.6 (2020.10.04)
PHP >=5.5.0 required
WordPress >=3.7.0 required (but not tested against latest versions).
Requires PHP >=5.5.0 w/ PCRE + MySQLi support.
Requires WordPress >=3.7.0
Not compatible with Windows O.S. (requires Unix-like O.S.; e.g., Linux, BSD, etc).
[NS] NinjaFirewall (WP) 4.3.0 (2020.12.01)

[NS] NinjaFirewall (WP) 4.3.3 (2021.04.04)
[NS] NinjaFirewall (WP) 4.3.4 (2021.05.30)
NinjaFirewall (WP) 4.4.0 (2021.07.29)
[NS] NinjaFirewall (WP) 4.4.1 (2021.09.19)
[L] NinjaFirewall (WP) 4.4.2 (2021.09.20)
NinjaFirewall (WP) authored/released by NinTechNet.
PHP >=5.5.0 required
WordPress >=4.7.0 required
Requires PHP >=5.5.0 w/ PCRE + MySQLi support.
Requires WordPress >=4.7.0
Not compatible with Windows O.S. (requires Unix-like O.S.; e.g., Linux, BSD, etc).